Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

v2.2.3patch4 released to fix some problems

We've again fixed several issues. This patch can be applied to any site already running v2.2.3, v2.2.3patch1, v2.2.3patch2 or v2.2.3patch3. The patch fixes these issues:

* Problem fully upgrading an EAAS module youtube to media player configuration
* Fixes the navigation sidebar flyout view for bootstrap themes
* Fixes the renderAction to NOT require the full view name to process correctly (can now pass url/module/headline instead of url/module/showall_headline)
* Fixes broken pages if reCaptcha is not configured
* Prevents adding empty searches to the search query history
* Fixes the broken text module inline edit view
* Adds slideshow options if photo album gallery landing page set to slideshow
* Adds the missing toggle collapse mobile responsive layout feature of the sample bootstrap theme
* Allows setting menu collapse width in theme configuration settings!
* Adds responsive layout work-around for IE 6-8
* Updates CKEditor to v4.2.2
* Fixes some issues which could break an EQL (database) import during form table rebuilding
* Fixes date output of rss feeds
* Adds new 'Configure RSS Settings' button to the RSS module showall view (which displays a list of all RSS feeds on the site)
* Makes more of the bootstrap theme buttons appear correctly as bootstrap buttons
* (patch #2) Fixes several crashes introduced in patch1 due to misplaced bootstrap theme files
* (patch #2) Fix page crash (slingbar) when non-admin user logged in
* (patch #2) Fix page crash when displaying Event module Week view
* (patch #2) Now saves LDAP password as encrypted
* (patch #2) Fixes bad path for custom user profile extensions (and some other mangled paths)
* (patch #2) Cleans up sample bootstrap theme views (sidebar now in 'well', flyout sidebar in all subthemes)
* (patch #2) Updates Minify (minification script) to v2.1.7
* (patch #2) Fixes display of non-images when browsing for a 'link' in File Manager
* (patch #2) Now filters to display only images displayed in File Manager, when adding an image only file
* (patch #2) Adds missing 'Field Insert' editor plugin needed for Forms Report Designs
* (patch #2) Fixes ability to create online event registrations
* (patch #2) Fixes mangling of wysiwyg text in saving module configurations
* (patch #2) Fixes sending event reminders which wasn't working
* (patch #2) Fixes date display when editing an event in a series
* (patch #2) Fixes re-ranking of nested containers when one is deleted (we were leaving an empty container previously)
* (patch #2) Updates generateSiteMap.php (sitemap.xml) script to optionally add images and videos
* (patch #3) changes new privacy feature default to OFF unless set in site configuration due to sectionref issues
* (patch #3) adds new upgrade script to clean up the sectionref table
* (patch #3) fixes some form module submission bugs
* (patch #3) fixes bootstrap navbar to work correctly w/ 2nd level children when collapsed/responsive
* (patch #3) fixes default setting for noindex/nofollow being set to ON instead of OFF
* (patch #3) fixes regression bug when non-admin users could NOT add new modules when granted permission
* (patch #3) fixes some optional ajax pagination in events module
* (patch #3) fixes manage tags bulk edit
* (patch #3) fixes some IE9 crashes
* (patch #3) fixes regression bug where super-admins could not see other user's files
* (patch #3) fixes regression bug on add module views (standard & bootstrap) to correctly respond to selected items
* (patch #4) Fixes a quick upload crash when quick upload resize was set
* (patch #4) Fixes a form email issue when submitted with a file upload control
* (patch #4) Fixes a less compilation issue for template style sheets
* (patch #4) Fixes issue where we always loaded admin-global stylesheet
* (patch #4) Fixes some issues with the bootstrap theme slingbar and flyout sidebar
* (patch #4) Fixes loading of base system 3rd party styles including normalize (which wasn't being loaded) so they are now loaded first to be cascaded by our styles
* (patch #4) Adds some session resets when clear all caches is called
* (patch #4) Adds display of standalone pages for selection as default/home page

Patch #4 for v2.2.3

Statistics: Posted by dleffler


  • I tried updating this but it doesn't seem to be working properly. Am I missing something? I was able to update to the new version of exponent 2.1.0 PHP version 5.2.17 but this patch does not apply properly. Is there a special way to add it? I was just uploading it to my server.

    View article...
  • If I understand you correctly, you attempted to apply v2.2.3patch4 to a running version 2.1.0? The v2.2.3patch4 can only be applied to a version 2.2.3 system (v2.2.3, v2.2.3patch1, v2.2.3patch2, or v2.2.3patch3). You would need to install the v2.2.3 package on top of your v2.1.0 system to upgrade it to v2.2.3 first (which would overwrite the v2.2.3patch4 files at that time), then you can install the v2.2.3patch4 on top of it. You do NOT need to run the install/upgrade between all these steps. You could simply extract the v2.2.3 package into the exponent folder then extract the v2.2.3patch4 file into the same exponent folder.

    FYI, a 'patch' file only contains updated files specific to that version of exponent. And each version of exponent is designed to be updated to future versions (as long as the custom theme does not contain obsolete/deprecated 1.0 function calls.

    Here are some articles to help ensure your custom theme is current .

    In v2.2.0, v2.2.1, & v2.2.2 we left in some theme 1.0 compatibility code that will display recommended theme changes to become 2.0 compliant. If you think your theme is NOT 2.0 compliant, you may want to install one of those versions first, then log on, turn on error reporting, and browse around the site to see if any warnings about theme updates are displayed.

    View article...
  • Hello,
    for some reason after installing this patch I'm having issues with the button "Add Module". If I click that, the whole container disappears and I do not get any screen to select any module. So, the page stays the same except that container and the link "Add Module" disappears completely (it comes back if you refresh the page but adding modules is not possible).

    View article...
  • I can't reproduce this might try first turning on 'error reporting' and also opening the browser 'console' by hitting F12 and selecting the 'console' tab...then refresh the page and look for an error. Is this a Twitter Bootstrap 2 based theme?

    View article...
  • I loaded all EXP files again from the scratch (2.3.0 without the patch) and it seems that "Add module" works now, still checking other functions that all is ok. Maybe some file(s) were not correctly loaded previously or there is an issue with the patch files!

    View article...
  • I am using bootstrap 3 custom theme but also tried the package theme of bootstrap 3 and it failed in a same way. Error report brings only a notice about "ENHANCED
  • I added again the patch 4 on the top of the 2.3.0 and indeed it stopped to work again. Editing content is not possible (the editor is not loading) and "Add module" not working.

    View article...
  • I installed in another server Exponent 2.3.0 and tested. I could edit content (editor visible) and I could add a module. Then I upgraded the Exp with patch 4 and I can't anymore add modules.

    View article...
  • Taking a look at your scenario to see what might be the problem. The 'patches' were created manually copying files out of the main package/code repository

    View article...
  • As a note...this issue (add module view doesn't appear) is something fixed in the post 2.3.0patch4 code to be released in the next version/patch soon.

    View article...
  • I hit the same "can't edit" after applying p4. Looks like a perms problem. (Seem to have) fixed it with this:

    cd external
    find . -type d -exec chmod 755 {} \;

    Also seeing the same add module problem which isn't throwing anything in the apache log, but does leave this in the JS console in the browser:

    Resource interpreted as Script but transferred with MIME type text/html: "http://XXXXXXXXXXXX/framework/core/forms/js/inputfilters.js.php".

    View article...
  • The problem is the result of a regression bug and leaving in some template code which adds a 'hide' style if there are NO errors passed to the add module view...however in other frameworks we had hidden the main form, displayed a 'loading' graphic, then when loaded hid the 'loading' graphic and un-hid the form.

    This may also be in some 'edit' views for bootstrap 3. Which modules are you experiencing this in?

    FWIW, there will NOT be a patch5 due to the bulk of changes making the patch file almost as large as a full version package...therefore v2.3.1 released within the next few days or next week will be the equivalent of v2.3.0patch5. I have one nasty bug I want to squash before finalizing it.

    View article...
  • Thanks for this info!
    I got the fixed framework/modules/container/views/container/edit.bootstrap3.tpl
    and now I can add modules again.

    View article...
Sign In or Register to comment.