Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Can't get to install pages

I'm trying to update my site to 2.3.1. I downloaded the zip of 2.3.1. I then uploaded it to my server and extracted it. Then I made sure the permissions were correct by running these commands: find . -type d -print0 | xargs -0 chmod 0755 and find . -type f -print0 | xargs -0 chmod 0644.

Then I tried going to and starting the install routine. However it redirected me back to the site's homepage.

View article...


  • As of v2.3.1 (actually v2.3.0patch3) you must now be logged in as an admin user to perform an upgrade. Trying to perform an upgrade/install without the proper conditions will redirect you back to the home page to prevent hijacking of sites. Try logging in at first, then do the upgrade, you'll also notice that when the upgrade is finished you'll be taken back to the running site instead of having to log in again.

    View article...
  • Do we need folders "Swift-5.1.0" and "fedex-phpv13"? They were left after upgrade in the server.

    Just to note that the server has php version 5.2.17 (install script marked it ok).

    View article...
  • Now after several refreshes, it's not written any fatal errors on the site, but the whole site is completely blank. I turned on the development variable and logger in the config but not getting any debug / log file in the server either.

    Is it correct that we should have both folders "lessphp" and "less.php"? (located in external)

    View article...
  • I got this upgrade through logged in as an admin but as soon as I'm "taken back to the running site", it looses its stylesheets (blank page with navigation only) and says this fatal error:
    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 128 bytes) in /home/niininn/public_html/portfolio/external/less.php/lib/Less/Tree/Selector.php on line 61

    When I refresh the site, it gives always the "exhaustment" of something but related to a different file. All of those are below "external/less.php/lib/Less/Tree/" though.

    View article...
  • The folders 'Swift-5.1.0' and 'fedex-phpv13' are both obsolete in Exp v2.3.1, but not added to the 'remove old files' upgrade script. However, the lessphp & less.php are two different .less to .css file compilers. 'lessphp' is the older one which works well EXCEPT for Bootstrap 3 and 'less.php' is the newer one which will compile Bootstrap v3.

    PHP v5.2.17 should work, but it is considered obsolete now that v5.6.0 stable is out and also v5.5.x is available along with v5.4.x...even v5.3.x is considered obsolete and will no longer be supported by the php guys. HOWEVER, it looks like your php.ini only has about 64M of ram allocated when the default is 128M. It's possible that PHP is running out of memory when compiling the bootstrap .less files. Though I've tested in many php versions from 5.2.1, thru 5.2.17, 5.3.5, 5.3.29, 5.4.33, 5.5.17, & 5.6.0, I've not tested them with less than their default settings.
    php.ini should have memory_limit = 128M or larger

    The reason you are seeing a 'blank' page is likely the Bootstrap .css files are not fully compiled. If you are NOT using a Bootstrap 3 theme, you can switch over to the older .less compiler by adding the following line to your /framework/conf/config.php
    if (!defined('LESS_COMPILER')) define('LESS_COMPILER','lessphp'); You could also leave 'Error Reporting' turned on, empty the /tmp/css folder (.less compiler cache) and then try loading the page again.

    View article...
  • I'm using a Bootstrap 3 them. I'll contact the server. This is another server hotel than my usual installations, so it can very well be the issue although the older Exp worked there.

    I have "Error reporting" on and I have emptied the tmp folders several time but nothing happens and neither anymore any error messages, only blank.

    View article...
  • This was solved few days ago, just reporting back:
    it was solved by setting
    php.ini should have memory_limit = 256M

    via htaccess actually

    View article...
  • Great, just curious, did you try 128M? Did it not work and you had to move up to 256M?

    View article...
Sign In or Register to comment.