Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

WYSIWYG editor

I updated a site to 2.3 from 2.2.3 patch 4 just now. When I try to edit (or create) a text item I do not see any text editor at all.
photo ScreenShot2014-05-01at101736AM_zps9834e425.png

What did I do wrong?


View article...

Comments

  • I've added a blog article descibing some of the issues and features of v2.3.0 http://www.exponentcms.org/blog/are-you-having-a-facelift-letdown and will have a patch out by the end of the week to address some issues we've already discovered (the fixes are already available using a git pull from the 'master' github repo branch.

    If the WYSIWYG editor (CKEditor) doesn't appear, there may be a conflict between 'Minification' and CKEditor. Several different ways to work around this issue are:
    - Turn Minification OFF using the Exponent, Super Admin Tools, System Cache menu
    - Leave Minification ON, but turn off 'Minify and Combine linked js scripts' using the 'Minify' tab of the Configure Website command found on the Exponent menu
    - Switch to begin using the new optional TinyMCE WYSIWYG editor (see below)


    View article...
  • Turning off minification fixed it for me. That was one thing I didn't think to try.


    View article...
  • Looks like it's a ckeditor module loading issue. If we load ckeditor.js via a combined/minified url, ckeditor then trys to load each of its plugins and styles using the same url.


    View article...
Sign In or Register to comment.