Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Moving Subfolder

You are a genius!!

Thank you, thank you, thank you.

View article...


  • Try deleting all the files in the /tmp/css folder. I've never seen this error, but it appears the less compiler cache was corrupted and it is attempting to recompile the core .less files based on bad locations. You also might delete all the files in the /tmp/views_c folder...then run the upgrade once again.

    View article...
  • Hi.

    I tried to follow the various steps suggested above, but when I finally ran the upgrade, visiting, I received the following error messages:

    Simple Site Upgrade

    Upgrading to v2.2.3 (Build Date: November-01-2013) from v2.2.3 (Build Date: November-01-2013)

    Fatal error: Uncaught exception 'Exception' with message 'load error: failed to find /web/htdocs/' in /web/htdocs/ Stack trace: #0 /web/htdocs/ lessc->compileFile('/web/htdocs/www...') #1 /web/htdocs/ lessc->cachedCompile(Array, false) #2 /web/htdocs/ expCSS::auto_compile_less('framework/core/...', 'framework/core/...', Array) #3 /web/htdocs/ expCSS::pushToHead(Array) #4 /web/htdocs/ expCSS::updateCoreCss() #5 /web/htdocs/ include('/web/htdocs/www...') #6 {main} thrown in/web/htdocs/ line 1818

    Any suggestion on what I did wrong and on how I can solve the problems?
    Thanks again.


    View article...
  • As always, you might want to save/export the database, so you can restore it later if needed. First, there is no straight upgrade path from 0.9x to 2.x, so you best bet would be to first delete everything in the main folder EXCEPT the /files and /exponent-2.2.3 folders (it would be good to have a backup of the files just in case), which would include the dot files like .htaccess. Then you can copy/move the files from /exponent-2.2.3 into the root or simply extract/install the 2.x files into the root folder and copy /exponent-2.2.3/files to /files. Again, making sure you have the 2.x .htaccess file in the root folder. I would then recommend you run an 'upgrade' by visiting

    Most of the content should 'survive' a move between folders EXCEPT images inserted into text since the urls point to a folder location (unless you leave the /exponent-2.2.3/files folder in place)

    Otherwise, it's not clear what you mean by 'the site is not visible'. You might try to manually turn on error reporting by editing the /framework/conf/config.php file and changing the DEVELOPMENT line setting from 0 to 1 which should cause a message to appear on a page with problems listed.

    View article...
  • Hi.

    I have a running website created with Exponent 0.9 ( The address points to a subfolder named ita ( I recently downloaded and installed Exponent 2.2.3 and I created a new version of my website within a subfolder called exponent-2.2.3 ( Both versions of the website work fine. If a search for, I see the old version of the website (which is located within the subfolder called ita). If I search for, I see the new version of the website.

    I would like to move the new version of the website within the root so that the new home page would appear as (instead of and the other pages of the new version of the website would appear as, instead of How can I do this? If I simply move the various files and folders that reside within the subfolder exponent-2.2.3 to the root folder, the new version of the website is not visible, anymore. I also tried to rename the subfolder called exponent-2.2.3, using a name more pertinent to my website, but again, if I do so, the new version of the website does not appear.

    Thank you for your support. Regards.

    View article...
Sign In or Register to comment.