Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

v2.4.2 now available

If you are already running any previous version of Exponent you are strongly encouraged to upgrade. However, we recommend you test the installation before upgrading a production server. You MUST be logged in as an admin user to upgrade Exponent. 

If you are not running at least PHP v5.5.x (yes, the minimum requirement is now PHP v5.5!), you will see a blank page when attempting to browse to the site, and an error message if attempting to install or upgrade. We also no longer automatically display a login box on the 'maintenance' view. You must specifically attempt to log on with the siteurl/login.php command and the database must be up and running.

If you update via 'git' you may experience a merge conflict due to the MANY changes. The best remedy is to have saved your database (eql file), files archive, and config.php file and when performing the 'git pull', if you receive a 'merge conflict', do this:

git fetch origin master 
git merge -s recursive -X theirs origin/master

If you are updating from any version prior to v2.2.0 and you've been updating your themes and custom modules in accordance with all the previous updates, this will be a simple update like the others. However, if you still have some patched old school stuff (your theme makes calls to exponent_theme_xxx or has custom old school module views), you may have some tweaking to do first. What this means for the site admin is:
  • When you install this software version, it'll seem as if the site has been wiped because all the modules and content will disappear UNTIL YOU RUN AN UPGRADE (as recommended)
  • All of the old school modules will be upgraded and deleted (calendarmodule, simplepollmodule, navigationmodule, containermodule, formmodule/formbuilder, etc...)...all those files in the /framework/modules-1 folder
  • Any old school module custom views MUST be upgraded/edited manually. See the post in the 2.0 Installation forum for details.
  • Details on upgrading can be found here.
v2.4.2 Download

Comments

  • Does 2.4.2 cause YUI to need to specifically declared in the theme template? Also what browser versions do you consider to be obsolete?
  • You do NOT have to declare YUI as a theme framework (like you do with the bootstrap versions), but you will need to use the YUI loader call in the {script} blocks (again, nothing changed)...YUI is only loaded if there has been a call for a YUI module (unlike jQuery which is always loaded)

    Obsolete would be anything that is not HTML5 compliant, specifically those that previously needed a shim (helper) to be able to display pages correctly. Primarily this might affect Internet Explorer versions less than v11 (Edge in Windows 10 is considered Internet Explorer v12/v13). Most of the versions of Chrome and Firefox that have been out for several years should be ok also. Again, the intent is to 1) keep from having to load a bunch of 'shims' to provide features to antique browsers, and 2) not facilitate those using insecure software/systems which may in turn open up the site to an attack.

    Here's a browser checking script I load on my sites (with a code snippet module in the footer). http://browser-update.org/  
Sign In or Register to comment.