Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Eql is empty


I try to back up the database, but my .eql file is empty (0 kb)


  • Assuming v2.4.1p6? I've not experienced problems before unless the database is larger than PHP is configured to handle (some of the tables can get quite large like search index, esp. in ecommerce). You might try a sample backup of only one table. If you run the database manager, it'll show the 'data length'. You can break up the backup into 2 segments and when you restore, it ONLY replaces what's in the EQL file (no other tables)
  • Yes, it's v2.4.1p6.  It's not a ecommerce site (that module doesn't meet european needs).
    And yes, this works, sort of. Tried in 2 parts, got one that had data and another that was empty. I haven't seen any data length anywhere? 
    To see where it comes from I tried the following:
    Optimized the database. Noted the optimized tables. Checked those for backup. And got another empty file... So somewhere there's a large table...but I don't know which one. It's a bit much to back up and restore table for table. 

  • If you open the Database Manager under the Exponent menu, Super Admin Tools, Database, Manage Database...the initial page displays all the tables and you'll note the size under the 'Data Length' column in the Database Manager.
  • Tried that, but it gives me this notification:

    Access denied for user 'name database' (using password: YES)

    You must already be logged into Exponent!

    which of course already am...use field to login to
Sign In or Register to comment.