Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Firefox 'Your connection is not secure'

I'm linking to pdf files on my web site and Firefox is giving this message: 'Your connection is not secure'

Would really appreciate help on how to fix this.

Comments

  • Just so I understand, you are trying to insert a link within the content on your site to a pdf file located on another site...and when a user clicks on that link (to the external pdf), using Firefox they receive the error?

    In general terms (according to Mozilla), the error occurs when the PC thinks the https:// link is to a site with a bad security certificate, which means their certificate is bad/outdated, or the clock is wrong on your PC, or some other possible issues.
  • Yes, your summary is right - thank you!

    I'm trying to link to a pdf at my (exponent) site - how do I rectify the security certificate issue?

    Thanks again!
  • Could you send me the link to those PDFs (dleffler@hughes.net)
  • edited November 15
    In Avast security products you can disable the interception of secure connections: Open the dashboard of your Avast application. Go to Settings > Active Protection and click Customize next to Web Shield. Uncheck the Enable HTTPS Scanning setting and confirm this by clicking OK.
    visit: custom essay writing service
  • In this case it's cause was accidently adding an https:// to the link, but it pointed to a site that wasn't set up to support https:// protocol
Sign In or Register to comment.