Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Recently getting errors on Exponent website using older version. Searching for fix or upgrade path.

Hi,

I have a website that has been running on Exponent since forever on version 0.96.5 (yeah, I know).  Recently, the site started showing these errors instead of loading content modules:

Notice: Trying to get property of non-object in /hermes/bosnaweb02a/b2280/sl.skif-qcc/public_html/modules/navigationmodule/class.php on line 337

The website host support tells me it's a scripting issue probably related to incompatibilities with the latest PHP version they have installed.

I'd like to quickly fix the issue if possible, or if I need to upgrade I would need to know what would be the upgrade process to get from that version to the latest.

Thanks!

Comments

  • Oh, if you want to see the errors, you can check the website at www.skif-qc.com
  • These are PHP 'warning' not errors.  Your easiest solution may be to Turn OFF error reporting
    • Got to Site Administration
    • Under the Development category,you'll see the 'Turn Error Reporting Off' link
    A better fix would be to 'MIGRATE' the site to Exponent v2.3.x which works with modern versions of PHP (those which have not been deprecated)...however, the theme may have to be tweaked.  http://docs.exponentcms.org/migration
  • I've also noticed another problem within your theme/subtheme template(s) (the index.php within your theme folder and all the files with the /subthemes subfolder).  The php call to expTheme::head() is located within the html <body> tags and NOT within the <head> tags.  This is the call that initializes the web page.
Sign In or Register to comment.