The place to discuss all things related to the Exponent Content Management System

Photoalbum module thumbnail problem

edited April 2013 in Modules
Hi everyone, I've just tried adding photos to this module (.jpgs) and am getting an error. My site is not on the internet yet so I am using WAMP to test it on. The thumbnail does not show and I am getting this error message when I click on it:

phpThumb() v1.7.11

\"C:/wamp/www/website/files\" is not a file

Has anyone seen this before / can point me in the right direction?


  • First off, as a development help, when phpThumb can NOT display the thumbnail it displays the error output in the thumbnail area...when you turn development/error reporting off, you'll see the 'not found' graphic instead.

    If you've copied the literal message in that it's looking for a file named "C:/wamp/www/website/files", of course it's NOT a file, it's the folder in which all the files are located.

    Does the file appear correctly within the File Manager Info popup? (or if you turn file manager thumbnails on?)

    You might do a 'Delete missing files' command from the bottom of the file manager to get a list of all files which are listed in the file manager and the file doesn't actually exist on the server. This will also list the filename and folder for the file.

    E.g., on my local uWamp system the error appears as

    \"C:/wamp/www/website/files/image.jpg\" does not exist
  • Thanks for the reply, the picture appears fine in the file manager. I did a delete missing files but its still the same. It does show a missing image thumbnail like this:


    Yes the full error actually reads

    \"C:/wamp/www/website/files/image.jpg\" does not exist

    I'm not sure what to do really?
  • Again, just to confirm...the actual graphic appears in the file manager?
    And the 'missing graphic icon' appears on a standard page when you turn development/error reporting off?
  • Yes that's right - images are fine in File Manager.

    With error reporting ON I get this image on the thumbnails page:

    With error reporting OFF I get this image on the thumbnails page:

    Hope that helps!
  • ok, if you want to help debug, edit the /thumb.php file.
    • On line #37 insert this code
      $_GET['phpThumbDebug'] = '0'
    • that would be on the line ABOVE the 'require_once' line[/*]
    • Open the browser console/firebug (usually F12) and select the 'console' pane[/*]
    • refresh/browse to the page and you should see phpThumb spit out a bunch of output[/*]
  • Ah got a message now! I've attached what it throws out....

  • Just an update - when I hover over where a thumbnail should be the status bar reads


    so i'm not sure it's looking in the right place? I notice that whenever I made a change (for example edit text in a text module or add files to the file module) as soon as I click save it takes me back to the home page rather than staying on the current page.

    I remember something about overrides.php in 0.97 but am not sure about this? could this be the problem?
  • You are correct, it should have an id#...basically the photo album module is passing the file id of the photo item to thumb.php to display it. thumb.php in turn parses the id replaces it with the 'src' filename which it passes on to phpThumb.php.

    The 'src' passed is based on concatenating the expFile(id#) directory and filename fields. The 'hover' should display the expFile->id and the 'w' should show the 'Box size for enlarged images' setting.

    Is it possible that 'cookies' are turned off on the server? PHP sessions act pretty odd without cookies (e.g., it can't keep track of details between page loads).
  • I asked and they said cookies are enabled. It's really getting me down because the gallery is the only part that doesn't work now - and typically it's the largest attraction of the site. I'm stumped. Is there anything else you can think of? Did the debug code I posted mean anything to you?
  • Perhaps I'm this a local test/development server or is this on a production (in-house) server? Since I see a lot of references to C:\ and localhost, it's NOT on the internet,

    And YES, the debug code tells me quite a bit about your setup and esp. that the params are NOT being passed to the thumbnailer...I've been out of town the past several days, but will try to see why or how the file path is NOT being passed in the view.
  • What version of Exponent are you running?
  • Hi dleffer - thanks for all of your help on this. Yes its on my PC not the internet as I don't want to upload it while the gallery is not working. I'm testing it using WAMP server and the details are Apache 2.2.17, PHP 5.3.3, MySQL5.1.53. I've installed it in c:\wamp\www\rps - everything works really well apart from the image gallery.

    The version of exponent I'm using is 2.1.3 - hope thats of some help!
  • Sorry to keep bouncing back and forth with you...could you edit one of the photo album items and verify there is a file attached to the item. (Files | Limit: 1) and it should NOT be (Files | Limit: 1 | Add Files | Quick Add, You need to add files)

    And if there is a file attached, please also verify the thumbnail is displayed between the red X and the filename.
  • Something else you might try...create a test install in a subfolder of this installation with a new database and install the sample data. This includes several graphics in a sample photo album, plus graphic icons in the menu. Let's see how that works?
  • Thanks dleffler - I'm away at present, back at the start of next week so I will try your ideas then and let you know how I do :D
Sign In or Register to comment.