Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Minify problem calc()

I've found a minfy problem in 2.4.3 p1: I've used  top: calc(20% + 60px);. In the minify, the spaces are removed, so browsers don't recognise it (it becomes calc(20%+60px))

Comments

  • Is this in an external stylesheet, or within a template? In v2.4.3 we switched the 'inline' CSS minifier to CSSmin.php because the base minifier was removing too many spaces, but the minifier for external sheets is still the base minifier.
  • No, it's within a template. Funny thing is, is that calc(20% - 60px) is being minified correctly.
  • I've added a possible fix by returning to use JSMIN instead of CSSMIN for inline css minification (as we did before v2.4.3). The default behavior will now be to use JSMIN, but it could be turned off under Site Configuration by unchecking that option which will then have it use CSSMIN as we've done in v2.4.3+. Again, this option will appear in the next release which should be out very very soon.
  • edited 1:44PM
    This was fixed in v2.5.0 released a few days ago. We've reverted to the old JSMIN compressor, but you'll find a new option under Site Configuration, Minify tab to disable JSMIN for css compression and thereby use CSSMIN.
Sign In or Register to comment.