Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Media player can´t play Youtube video

Hi, I´m using Exp 2.4.1 patch 6. In this version media player module can´t play Youtube videos. the link is there but when I click play buton nothing hapens. Uploaded videos works fine. Any clue what is happening? Can I solve the problem Updating  to version 2.4.2 ?

Comments

  • Embeded YouTube links in the MediaPlayer work locally with the latest Exp version...mediaelement.js was updated to the latest version 4.2.8 in 2.4.2patch1, while Exp v2.4.1patch6 was using medaelement.js v4.2.5
  • I try upgrade to 2.4.2 patch 4 but the video problem is the same and the exponent toolbar desapear;
  • It seems like the javascript on the page is breaking and preventing the toolbar from appearing. Try opening the browser developer tools (F12), the refreshing the page, and looking at the 'console'.
  • I put in development mode and the messages are : 
    The key "25" is not recognized and ignored.
    jquery-migrate-3.0.1.min.js:33 JQMIGRATE: Migrate is installed, version 3.0.1
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #Submit: (More info: https://goo.gl/9p2vKq) <button type=​"submit" id=​"Submit" class=​"submit btn btn-primary btn-sm " value=​"Login">​…​</button>​ <button type=​"submit" id=​"Submit" class=​"submit btn btn-primary btn-sm " value=​"Login">​…​</button>​
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #action: (More info: https://goo.gl/9p2vKq) <input type=​"hidden" name=​"action" id=​"action" value=​"login">​ <input type=​"hidden" name=​"action" id=​"action" value=​"login">​
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #controller: (More info: https://goo.gl/9p2vKq) <input type=​"hidden" name=​"controller" id=​"controller" value=​"login">​ <input type=​"hidden" name=​"controller" id=​"controller" value=​"login">​
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #form: (More info: https://goo.gl/9p2vKq) <form role=​"form" id=​"form" name=​"form" class method=​"POST" action=​"/​index.php" enctype=​"multipart/​form-data" novalidate=​"novalidate">​…​</form>​ <form role=​"form" id=​"form" name=​"form" class method=​"POST" action=​"/​index.php" enctype=​"multipart/​form-data">​…​</form>​
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #int: (More info: https://goo.gl/9p2vKq) <input type=​"hidden" name=​"int" id=​"int" value>​ <input type=​"hidden" name=​"int" id=​"int" value>​
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #password: (More info: https://goo.gl/9p2vKq) <input id=​"password" type=​"password" name=​"password" value size=​"25" class=​"password  form-control" required=​"required" caption>​ <input id=​"password" type=​"password" name=​"password" value size=​"15" class=​"password  form-control" placeholder=​"Senha" required=​"required" caption>​
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #src: (More info: https://goo.gl/9p2vKq) <input type=​"hidden" name=​"src" id=​"src" value=​"@random5926ff17191ce">;​ <input type=​"hidden" name=​"src" id=​"src" value=​"@random59270b34c4ebb">;​
    untitled-1495650221-0.91529700:1
    [DOM] Found 2 elements with non-unique id #username: (More info: https://goo.gl/9p2vKq) <input id=​"username" type=​"text" name=​"username" value size=​"25" class=​"text  form-control" autofocus required=​"required" caption>​ <input id=​"username" type=​"text" name=​"username" value size=​"15" class=​"text  form-control" placeholder=​"Usuário" autofocus required=​"required" caption>​
    untitled-1495650221-0.91529700:1
    This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.
    untitled-1495650221-0.91529700:1
    Error in event handler for (unknown): TypeError: Cannot read property 'indexOf' of undefined
  • and at the top of the page the message is :
    Warning: session_start(): open(/var/lib/php/session/sess_c6ebc3ee5f8de6ab0c476ec9dbed49cd, O_RDWR) failed: Permission denied (13) in /home/storage/f/4f/76/tuaregraftingexpedic/public_html/framework/core/subsystems/expSession.php on line 132

  • The Session error (at the top of the page) is a server (configuration) error...either by server permissions, or the server has run out of space in it's 'tmp' folder (used to store session data). It's possible it could be the root issue.

    The other warnings (in the preceding message) are mostly notices except for the last one...and the (unknown) makes it hard to track down, but could 'break' the page's other javascript.
  • I tryed a fresh install but the message abouve still there:
    Warning: session_start(): open(/var/lib/php/session/sess_c6ebc3ee5f8de6ab0c476ec9dbed49cd, O_RDWR) failed: Permission denied (13) in /home/storage/f/4f/76/tuaregraftingexpedic/public_html/framework/core/subsystems/expSession.php on line 132
    witch directory is blocked? I unlock install and tmp with all subdirectories

  • Again, that issue appears to be with the web server itself and my past experience shows it is usually the server /tmp device is out of storage space (do not confuse this with the /tmp folder within the web space used by Exponent). You may need to call your host provider to correct that issue.
  • I tryed everything to install version 2.4.2, even a fresh install but when I did with all checks, after I login as admin the Exponent Toolbar not appear; I check developer option and there are no errors. Please help.
  • Were you able to get your host provider to help? If the server doesn't have enough storage space for the session, it'll act odd in regards to logging in since PHP won't be tracking user sessions correctly and even though you think you've logged on the web server PHP doesn't have a record of it.

    Therefore, there are two reasons the Exponent toolbar won't appear if logged on as an admin
    1) you have a web host server issue which isn't allowing PHP sessions, so PHP doesn't know you're still logged on
    2) there is a javascript error on the page, this can be checked by opening the browser developer tools F12, and looking at the 'console' output while loading the page.
  • OK, some questions:
    - The version 2.4.1 patch 6 is running fine. What´s the diferrence between there and version 2.4.2?
    - All the installation checks passed. Have any more check to do after installation? 
    - Can I run the update procedures outside the exponent, running some .php directelly?
    - After installation I can´t run index.php any more. Why?
    • For security reasons, you MUST be logged into Exponent as an admin to run the upgrade/update process.
    • The list of changes from 241p6 to 242 are listed at the top of the changes-v242.md file.
    • I am assuming you are running 241p6 with few issues other than media player youtube links?
    • I am assuming you are able to complete the upgrade process through all the steps, but it fails at the final step when you click on the 'Finish Upgrade' button?
    • Are you selecting any of the 'optional' upgrade scripts? What kinds of messages do you receive from the other upgrade scripts (such as # of item fixed, etc...)
    • When you say you can't run index.php what sort of output do you get (blank page, 500 server error, permissions error)?
    I'm not sure if you are trying to upgrade to plain v242 (not patches) or v242 and patch 4? It is ok to extract both v242 and patch 4 before running the upgrade. I'm planning to have patch 5 out in the next 24 hours.
  • Answers
    - For security reasons, you MUST be logged into Exponent as an admin to run the upgrade/update process. CORRECT, I´M LOG AS ADMIN

    The list of changes from 241p6 to 242 are listed at the top of the changes-v242.md file.
    - I´LL READ THANKS

    I am assuming you are running 241p6 with few issues other than media player youtube links?
    - YES

    I am assuming you are able to complete the upgrade process through all the steps, but it fails at the final step when you click on the 'Finish Upgrade' button?
    - YES

    Are you selecting any of the 'optional' upgrade scripts? What kinds of messages do you receive from the other upgrade scripts (such as # of item fixed, etc...)
    - CAN´T REACH THERE, STOP IN STEP BEFORE

    When you say you can't run index.php what sort of output do you get (blank page, 500 server error, permissions error)?
    - NO. I´M TRYING 
  • Upgrade steps
    • 1st page - introduction
    • 2nd page - System Requirements check completed report
    • 3rd page - Database Tables update completed report
    • 4th page - List of Upgrade scripts
    • 5th page - (repeat of 4th page) list of completed Upgrade scripts, Button to complete upgrade
    • 6th page - Theme stylesheets recompiled and you should land on the Home page
    Based on what you've said, you see the 2nd page, but not sure if you complete to see the 3rd page or 4th page.

    In the /exponent_version.php file, uncomment the line which turns on error reporting during an installation near the bottom of the file. This may help discover what is taking place.
    //        define('DEVELOPMENT','1');
  • Answers

    When you say you can't run index.php what sort of output do you get (blank page, 500 server error, permissions error)?
    - NO. I´M TRYING WRITE IN THE BROSWER AS THE FIRST INSTALL: .../INSTALL/INDEX.PHP BUT THE INSTALL PROCEDURE DOESN´T RUN JUMP TO INDEX.PHP IN THE EXPONENT ROOT. IN OTHER VERSION I CAN ACCESS THE INSTALL AGAIN, AND FIZ SOME PROBLEMS, WITH THIS PROCEDURE.
  • edited March 16
    OK, I upgrade to vs 242p4 but the mediaplayer problem still there. Did you mention 2.4.2patch1 but it is not avaible. Have any other form to check mediaplayer problem?
  • By chance, do you have more than one video on a page?
  • Definitely broken if there is more than one youtube video on a page...fix will be in next patch (242p5)
  • edited March 17
    Problem Fixed. Thanks

Sign In or Register to comment.