Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

v2.4.2patch6 released to fix several Issues

edited April 30 in Announcements
This patch addresses issues with forms, crashes when pulling in iCalendar feeds, and some PHP v7.2.x issues,in addition to other minor issues. We strongly encourage all Exponent installations be upgraded to v2.4.2 with this patch as soon as practical! Patch #6 to v2.4.2 is found at https://sourceforge.net/projects/exponentcms/files/exponent-2.4.2-patch-6.zip/download

NOTE: You may need to perform a manual update after installation of this patch if you installed an earlier version of the patch #5 release (version would be displayed as 2.4.3 Develop). A manual update can be performed if you are logged in as a super-admin and taking the browser to yoururl.org/install/index.php.

v242patch6 adds these features to v242 and previous patches:
- update robots.txt to remove thumb.php thumbnailer since Google indexing has begun to complain...also disallowing newer documents
- adds customers command (manage users) to ecommerce menu
- adds forms quick-submit option to skip form entry confirmation for a 1-step submission

v242patch6 fixes these issues in v242 and previous patches:
- fix slideshow scroll page up/down on touch devices
- regression fix (v242p5) form submission warning
- give proper ids to event feedback forms to prevent errors when multiple RSVP events are shown on page
- fix expString and billing calculators to be php v7.2 compliant (remove each() statement)
- regression fix recaptcha (form submission) was broken when minimize & combine js scripts was turned on
- regression fix (v242p5) remove orphan child product records upgrade script
- regression fix (v242) crash with ical pull events time zones
- fix a twitter profile image issue; add 'noq' param to {img} to preven tacking on &q=75 to twitter call for profile image

v242patch6 updates these 3rd party libraries in v242 and previous patches:
- CKEditor to v4.9.2
- TinyMCE to v4.7.11
- elFinder to 2.1.37
- jquery datetimepicker to v2.5.20
- mediaelement to v4.2.9
- owlCarousel2 to v2.3.4
- moment.js to v2.22.1
- easypost sdk to v3.4.1
- EmailValidator to v2.1.4
- Bootstrap DualListBox to v3.0.7
Sign In or Register to comment.