Please disregard the 'View article...' shown at the bottom of many posts as this is the result of restoring old forum posts from a backup.

Editing any settings or module content opens in the front page of the site

I have a page with a custom theme having basically index.php for all pages except the front page is frontpage.php. Now when I set it up, something goes wrong since when ever editing a module content, adjusting any settings, it opens all on the front page view, not on the index view. 

How should this be debugged that would find the proper way to set it up?

Comments

  • Do you have an 'action_map.php' file within the theme with lines which aren't commented out? The logic for selecting the theme/subtheme template is found in the expTheme.php subsystem file, the getTheme() function at line #574.
  • Ouch, didn't get any email that you had answered here.
    Yes, the lines not commented out are following:
    cart
    order
    report
    store
    blog

    The rest is commented out except of course the opening and closing of the php (and "the if sentence" related to it).
  • I do not see the website would act based on this exptheme.php logically. The fallback theme should be index.php, right? Anyway, it is falling to frontpage.php that is set up as a Default / Front page. 

    There are two type of "default" pages that confuse a bit but I have index.php page the one that is wished to be opened when editing any module or settings. It insists to open the frontpage.php all over when editing. 
  • I'll be out for a week...is it only when editing items on the 'front page' or when editing any item?
  • Editing anywhere.
    I think the loop is cut that it doesn't redirect it back to the right index theme. I sent via email earlier those two theme files. Maybe something wrong in those and I'm blind. 
Sign In or Register to comment.